プラグインエラー … 「wp-content/plugins/wordpress-23-related-posts-plugin/config.php」

2017/05/24 プラグインがエラーをだして、ページの表示ができなくなっていたようです。

OTETEは… 閲覧数少ないのでいいですが、てくてくひめじのほうでも同じ状況だったので、びびりました。

Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in /home/users/●●●●/wp-content/plugins/wordpress-23-related-posts-plugin/config.php on line 130

こんなエラーです。

ページの管理画面にも入れず、問題のプラグインを停止することができなかったので、FTPで入って 「 wordpress-23-related-posts-plugin 」 というプラグインを強制削除。
どうにか表示できるようになって、よかったです。

サーバがダウンしていたわけでもないので、監視ソフトから連絡がくるでもなく、どうやら数時間はおかしくなってた模様…。
プラグインを自動でアップデートする設定にしていたのですが、このプラグインがアップデートしたことによって、他のプラグインとの不具合なのかこれ単体の不具合なのかわかりませんが問題が起きたようです。

自動アップデート、もちろん停止しました。
面倒くさいからいいかなーと思ったのですが、結局結果、面倒くさいことに。

関連投稿を表示するプラグインで、見た目が気に入ってたのに残念です。
とりあえず他のを今動かしています。様子みて考えよう…。